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Working Model combines advanced motion simulation technology with sophisticated editing capabilities to
provide a complete, professional tool for engineering and animation simulation.    The dynamic simulation 
engine provides a translation of real world Newtonian mechanics to the computer, while the simple but 
powerful graphical user interface makes it easy to experiment with different scenarios and situations.
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You can browse the following topics for more information about the features of Working Model:
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A Word from Knowledge Revolution
We would like to thank you for purchasing one of our products.    At Knowledge Revolution, we are 
committed to providing you with quality products which are easy to use.    The product you have 
purchased is the result of thousands of hours of hard work by dedicated professionals.To provide quality, 
we are always listening to our most important source of feedback: customers like you.    We would like to 
know how you use our product and to know how we can better serve you.    We are constantly improving 
Working Model, and look forward to your comments and suggestions.    Please feel free to call me directly 
if I can be of service.

David Baszucki, President

Knowledge Revolution
66 Bovet Road, Suite 200
San Mateo, CA 94402

(415) 574-7777



 Working Model Features
Knowledge Revolutions Working Model® 3.0 combines advanced motion simulation technology with 
sophisticated editing capabilities to provide a complete, professional tool for engineering and animation 
simulation.    The dynamic simulation engine provides a translation of real world Newtonian mechanics to 
the computer, while the simple yet powerful graphical user interface makes it easy to experiment with 
various scenarios and situations.

Operating Concept

The operating concept of Working Model is simple.    Define a set of rigid bodies and constraints (e.g., 
motors, springs, and joints).    With a click of the mouse, Working Model uses its powerful simulation 
engine to put your model in motion.

Working Model allows you to fine-tune simulation parameters.    You can define controllers to adjust 
properties of objects.    You can create meters to plot the data that is taken during a simulation.    You can 
design a model in your favorite CAD program and import the data to Working Model.    You can even use 
another application such as Excel or MATLAB® to control your simulations.

Simulation Engine

The simulation engine of Working Model is designed for both speed and accuracy.    It calculates the 
motion of  interacting bodies using advanced numerical analysis techniques.    The engine allows the 
construction of complex systems, and computes their motion under a variety of constraints and forces.    
In addition to user-imposed constraints such as springs, pulleys, or joints, the engine has the capability to 
deal with world-level interactions, such as collisions, gravity, wind-resistance, and electrostatics.    The 
engine is fully configurable, and every aspect of a simulation from the time step (fixed or variable) to the 
integration technique can be specified by the user.      

Scripting with Working Model Basic
Working Model has an embedded scripting system called Working Model Basic, a programming 
language.    The language closely resembles Microsoft Visual Basic and gives full access to the complete 
Working Model database and features.

You can write programs to create, modify, and join bodies and constraints.    You can run iterative 
simulations overnight and export the data files for future review.    You can design custom dialog boxes to 
create a new simulation environment.    In addition, you can share scripts provided by third-party vendors 
and add them to Working Model's main menu.

Please refer to Working Model Basic User's Manual for instructions and language reference.

Smart Editor

The Smart Editor is the core of the user interface, keeping track of connections and constraints among 
objects as they are constructed.    To develop a mechanism, a user simply starts to draw the components 
on the screen and indicates where and how the pieces should be joined.      The Smart Editor allows the 
mechanism to be rotated and dragged, while maintaining the fundamental integrity of the components and
of the joints between them.    Users can position objects by using the standard click-and-drag paradigm, or
by specifying their coordinates precisely in dialog boxes.    In all cases, the Smart Editor makes sure that 
no link is broken and no mass is stretched.    A robot arm, composed of many parts held together by pivot 
joints, can be positioned accurately using the Smart Editor.      By clicking and dragging the hand, the arm 
stretches out to the desired conformation.

Object Snap
Working Model provides an automatic "snap" feature often seen in CAD applications.    As you create 
constraints and bodies, your mouse pointer can snap to certain predefined points on the body geometry, 



allowing you to position constraints and bodies precisely, right from the start.

Math coprocessor/FPU support

Working Model is designed to take full advantage your computer's math coprocessor (Floating Point Unit),
if one is available.    This speeds the computations enormously, allowing for faster, smoother animation.    
If no such unit is available, Working Model defaults to standard arithmetic.

Editing Objects On-the-fly
You can modify the geometry and position of various objects in Working Model very quickly by typing 
desired properties directly on the screen.    Simply select the desired object, and Working Model will 
present you on the screen what values can be edited on-the-fly.    Simply type the precise values, and the 
modification will take effect immediately.

Inter-application Communication
Working Model uses Apple events (Macintosh) or DDE (Windows) to communicate with other applications
during a simulation.      Users can specify physical models of real-life mechanical designs and then control 
them externally through other programs.      For instance, a Microsoft¨ Excel worksheet can be used to 
model an external control system.      Data is sent to the spreadsheet, which calculates the control signals,
and Working Model receives them, all while a simulation is in progress.

Further, other applications can send scripting commands (using WM Basic) to Working Model.    As long 
as the external application supports a few basic features of DDE and/or Apple events, it can send to or 
invoke an entire program in Working Model.

Although Working Model already provides a vast array of math functions, you can implement more 
advanced functions in another application and link them to a Working Model simulation.

Exporting Static / Animated Data
Working Model exchanges geometries with most popular CAD programs through the DXF file format.    
Numerical simulation data can be exported as meter data.    For the Macintosh, Working Model also 
supports standard PICT and QuickTime movie formats.    For Windows, Working Model supports Video for
Windows export.

On the Macintosh, you can export animated data in a variety of formats.      Working Model is a natural 
choice as a tool for creating animated images of unprecedented realism, since the program accurately 
models interactions of moving objects according to the real world dynamics with high accuracy.      The 
frame sequences themselves can be exported in a variety of standard file formats, including MacroMind 
Three-D, Wavefront, and DXF animation, allowing a seamless integration of Working Model files with 
animation programs.

Input and Output Devices
Real-time input devices include sliders, buttons, and text fields.      

Real-time output devices include graphs, digital displays, and bar displays.

Complete set of Menu Buttons
You can create a button to execute Working Model menu commands, including Run, Reset, and Quit.    
Buttons can simplify pre-made simulations for the first-time user.    With buttons, you can create Working 
Model documents that are similar to HyperCard stacks in that one document can lead to the next by the 
click of a button.

Text tool
You can annotate simulations directly on the workspace, using any font, size, or style of text.



Moving Graphics
You can paste pictures created with a paint or draw program directly on the workspace, as well as link 
them to objects.    For example, you can create a circular mass object and attach a picture of a baseball to
it.

Custom Global Forces    
You can now simulate planetary gravity as well as earth gravity, electrostatic forces, and air resistance 
proportional to velocity or velocity squared, or create your own custom global forces by supplying an 
equation.    For example, you can create magnetic fields, wind, and electron gun fields.

Extensive Graphical Features
You can show and hide objects, fill objects with patterns and colors, display how objects are charged (+ or
-), choose the thickness of an objects outline, show object names, display vectors in various ways and 
colors.

Multiple Reference Frames
You can now create different views using any mass or point as the frame of reference.    

Complete Control of Units
Choose from standard metric units such as kilograms, meters, and radians; standard English units such 
as foot, inch, yard, second, degrees, pounds; or other kinds of units such as light-years for measuring 
distance. 

Complete Scripting Language
Working Model has a scripting language for creating formulas that is very similar to the formula language 
used in Excel and Lotus 1-2-3.      

Equations
Any value can be a formula rather than a number.    For example, you can create a formula for a mass 
object that simulates a rocket, or create a formula for a force that simulates a sinusoidal driver.

No-Menu Player Documents

Player mode provides a simulation window with a limited menu bar and no palette, giving more room to 
display the simulation.    Player mode documents can be used by people who are not familiar with 
Working Model

Custom Tracking

You can track all objects or limit tracking to selected objects.    Individual objects can leave tracks of their 
outline, center of mass, or vectors.    You can also connect tracks with lines.

Object Layering

The simulation world consists of two layers:    one for user objects such as meters, and one for physical 
objects such as masses and constraints.    Full control of which objects collide is provided.

An Almost Infinite World

The simulation world can be as large as you like (up to ±1.0e4900 meters).    Zoom is infinite within the 
bounds of the world.



Vector Displays    

Working Model comes with a complete set of vector displays for showing velocity, acceleration, and force. 
Vectors can be displayed for electrostatic forces, for planetary forces, and at multiple contact points when 
two objects collide.

Save Time History

You can calculate and record complicated or time-consuming simulations overnight and play them back in
real time.    You can then save the entire simulation, to disk.

Group Center of Mass Object    

You can show the center of mass of all objects.    This feature is useful as a frame of reference for the 
center of mass in different views.

Pause Control    

Stop or pause simulations automatically.    For example, you can set the simulation to pause when two 
seconds have elapsed by entering the following formula:    Pause when time > 0.2.    You can also tell your
simulations to loop and reset.

Apply Control

You can apply forces and constraints at different times.    For example, you can apply a constant force on 
an object for one second, or you can apply a force when the objects velocity is greater than 10.

Unlimited Objects

You can create as many objects and constraints as your computers memory allows.    





 Guided tour
This guided tour uses sample simulations to help you learn how to use Working Model. Step-by-step 
instructions guide you through each task.

Starting Working Model 
Quick steps for creating a new simulation 
Running a sample simulation 
Setting up a simple simulation 
Measuring properties from a simulation 
Tracking objects 
Creating and editing a mechanism
Saving a simulation 
A projectile simulation with controls and menu buttons 



Starting Working Model

Have you installed Working Model on your hard disk? If not, please refer to the User's Manual for 
installation instructions.

The installation software creates a program group called "Working Model".    In the group, you will also 
see a program item representing the Working Model application.

To start Working Model:

1. Double-click the Working Model icon (program item).
Working Model starts up and opens a new, untitled window.

The new, untitled simulation document appears in its own window. You will see the Toolbar on the left and 
the tape player controls along the bottom of the window.

The Toolbar contains tools you will use to create simulations. Tools are provided for creating masses, 
springs, ropes, forces, and many other objects. The Toolbar also contains buttons for running and 
resetting simulations.

The tape player controls give you more control for running and viewing simulations. You can use the tape 
player controls to step through simulations, play simulations backwards, or move to a specific time in a 
simulation.



Quick steps for creating a new simulation

These quick steps provide an overview of how to use Working Model to create and run a simulation. 
Although the steps you take may differ depending on the type of simulation you are setting up, the basic 
steps for creating and running a simulation are as follows: 

1. Choose New from the File menu to open a new simulation document.
2. Draw and position bodies and constraints.

Use the Toolbar to draw objects just as you would with a paint or draw program.

3. Double-click an object to display and change its initial specifications (for example, velocity, 
friction, or elasticity).

4. Choose from the Measure menu to install meters and graphs that display the information to be
analyzed during the simulation.

5. Click Run in the Toolbar.
6. Choose Save from the File menu to save the simulation.



Running a sample simulation

In this exercise, you will open and run sample simulation documents included with the program.

1. Choose Open from the File menu.
The Open dialog box appears.

2. Double-click any of the demonstration directories using the Open dialog box.
The contents of the demos folder appears.

3. Select one of the demonstrations in the list by clicking on it. Then click on the OK button.
4. Click Run in the Toolbar.

The simulation will run.

6. To stop the simulation, click the mouse button.
Once you have finished watching a simulation, you should close it so that more memory is available 
for other simulations.

7. Choose Close from the File menu to close the simulation window.
A dialog might appear asking if you want to save the changes before closing.

8. Click No in the dialog box.
To watch other demonstration simulations, repeat steps 1 through 8 above.

To finish your session with Working Model, choose Quit from the File menu.



Setting up a simple simulation

In this exercise, you will use tools from the Toolbar to create a simple simulation. You will draw a circle to 
represent a projectile and specify its initial velocity. Then you will watch the projectile fly as you run the 
simulation.

Opening a new document
Creating a circle
Moving the circle to its starting position
Specifying an initial velocity
Running the simulation





Opening a new document

If any simulation documents are currently open, close them before opening a new document.

1. Choose New from the File menu.
A new, untitled document window appears.

Next you will create a circle to represent a body.



Creating a circle

The Toolbar provides a variety of tools for setting up simulations. To choose a tool, click on it.

To create a circle:

1. Click the Circle tool.
2. Position the pointer at any starting point in the blank area of the screen.

The pointer changes from an arrow to a crosshair. This means you are ready to create an object.

3. Click once, and drag the mouse.
Observe that the circle changes its size as you drag the mouse.

4. Click again to complete the circle.
A line appears inside the circle. During an animated sequence, this line indicates the circle's 
orientation.    Your simulation window should look like the figure below.



Moving the circle to its starting position

To position the circle for the start of the simulation:

1. Select the Arrow tool if it is not already selected.
2. Position the pointer anywhere inside the circle.
3. Drag the circle to the lower left corner of the screen.



Specifying an initial velocity

To specify the initial velocity of the projectile:

1. Click the circle to select it.
Four square dots appear around the circle when it is selected.

2. Choose Preferences in the World menu.
The Preferences dialog appears as shown below:

3. Check the item labeld "Allow velocity vector dragging" in the Preferences dialog.
4. Click OK to close the Preferences dialog.

Note that the circle as a blue dot at its center.

5. Position the pointer on the center dot in the circle and drag away from it to approximate the 
projectile's initial velocity.
While dragging, the arrow points away from the circle.

6. Release the mouse button at the desired initial velocity.
An arrow representing the projectile's initial velocity appears.    Your model should look like the 
following:



7. Drag the tip of the arrow to adjust the velocity.

If desired, the precise magnitude of the initial velocity can be specified and observed in the Properties 
window.    Select the circle, and choose Properties in the Window menu.    The Properties window appears
as shown below.



The fields designated as Vx and Vy are the x and y components of the intial velocity vector.



Running the simulation

You are now ready to run your simulation. To run the simulation:

1. Click Run in the Toolbar.
Voilá! Watch your first simulation run. Because normal earth gravity is on by default in a new 
document, the circle flies with the motion of a typical projectile.

Also, note that the RUN button has now become the STOP button, and your cursor turned into a 
STOP sign.

2. Click once anywhere within the document window to stop the simulation.
3. Click Reset in the Toolbar to rewind the simulation.
4. Go back to step 4 under Specifying an initial velocity and try running this simulation with 

different velocities.



Measuring properties from a simulation

Working Model allows you to measure many physical properties such as velocity, acceleration, and 
energy by using meters and vectors.

Meters and vectors provide visual representations of quantities you want to measure. Meters can display 
information in the physics world as:

numbers (digits)
level indicator (bars)
graphs

Vectors represent the properties of velocity, acceleration, and force as visual arrows. The direction of the 
arrow shows the direction of the velocity, acceleration, or force. The length of the arrow corresponds to 
the magnitude of the velocity, acceleration, or force.

In the following exercises, you will measure a projectile's velocity and display it in various ways. First, you 
will display it as a digital meter. Then you will change that meter to a graph. Finally, you will display the 
velocity of the projectile as an animated vector.

Displaying a velocity meter
Changing to a graphical display
Displaying vectors



Displaying a velocity meter

To display a digital meter that measures the velocity of the projectile, follow these steps:

1. Click Reset in the Toolbar.
2. Draw a circle in the lower left-hand corner of the workspace if you don't already have one. 

Select the circle.
The circle becomes selected: four small dots and the velocity arrow appear. If you already know how 
to create objects and give them initial velocities, just create a single circular mass, and give it an initial
velocity.

3. Choose Velocity from the Measure menu, and All from the Velocity sub menu.
A digital velocity meter appears, as shown below.

4. Click Run in the Toolbar.
As the projectile flies, you can monitor its velocity by watching the velocity meter.

5. Click on the Stop button to stop the simulation.



Changing to a graphical display

To change a digital meter into a graph:

1. Click Reset in the Toolbar to rewind the simulation.
2. Click the arrow in the top left corner of the meter as shown below.

The meter becomes a graph. The graph shows all of the values that were originally displayed on the 
digital meter. To view one particular property, click the buttons on the side of the graph until the 
desired property is the only one displayed. 

Choices that are gray will not be displayed. Choices that are white will be displayed.

3. Select Vy as the only property to be graphed by clicking in the buttons on the side of the 
meter.
Your graph meter should look like the following:

4. Click Run in the Toolbar.
5. Click the Stop button to stop the simulation.
You can install meters to measure every quantity shown in the Measure menu.



Displaying vectors

To display the velocity of the projectile as an animated vector:

1. Select the circle.
2. Choose Velocity from the Vectors menu.
3. Click Run in the Toolbar.

When you run the simulation, a vector appears on the circle, showing its velocity. 

4. Click on the Stop button to stop the simulation.



Tracking objects

Tracking shows the path of an object by recording its location at specific intervals. The following 
instructions generate an illustration you may be familiar with from physics textbooks.

1. Click Reset in the Toolbar if you have run and not yet reset the simulation.
2. Choose Tracking from the World menu, and then choose Every 8 frames from the sub menu.

When you run the simulation, Working Model will display the position of the circle every eight frames.

4. Click Run in the Toolbar.
The projectile's path is traced as it flies, as shown in the figure below:

5. Click once to stop the simulation.
The track will be erased when you create or edit objects.



Creating and editing a mechanism
In this tutorial, you will use the Working Model Smart Editor to create and edit a mechanism.    When you 
drag the mechanism with the mouse, it will move like a real mechanism.    The Smart Editor will enforce 
constraints while you edit.

 Constructing a Linkage Mechanism
 Modifying the Link Geometry
 Precision Numerical Assembly



Constructing a Linkage Mechanism
To construct a linkage consisting of three bars:

1. Create a new Working Model document by selecting New from the File menu.    
Close all open documents prior to starting this exercise.

2. Double-click the rectangle tool on the toolbar.    
The tool will turn black, indicating that it can be used multiple times.

3. Sketch a rectangle.
4. Sketch two vertical rectangles below the horizontal rectangle.
While you draw the additional rectangles, a small "X" symbol appears as you move the mouse pointer 
closer to the midpoints and corners of the existing rectangle.    This symbol indicates that the Object Snap 
feature is active.

When you start to create a rectangle while a Snap Point symbol is visible, the drawing is automatically 
aligned to that Snap Point.

After you draw the two vertical links, your screen should resemble the figure below.

Creating Pin Joints
You will now create pin joints.    A pin joint acts as a hinge between two bodies.    The Smart Editor will 
prevent joints from breaking during a drag operation.

1. Double-click on the Pin Joint tool.
The tool will turn black, indicating that it can be used multiple times.

2. Sketch two pin joints by clicking once with the mouse for each joint.    Try to attach it to a Snap
Point (where a small X symbol appears) whenever possible.
Note that the Object Snap is still active when you attach a constraint, such as a pin joint.    As shown 
in the figures below, possible Snap Points include the center of links and their corners.



After you create the two pin joints, your screen should resemble the figure below.

Pin joints automatically connect the top two bodies.    If only one body lies beneath a pin joint, then the pin
joint joins the body to the background.

3. Select the Arrow tool by clicking on the toolbar.
4. Try dragging any rectangle.

All three rectangles will follow the motion of the mouse, because the pin joints connect them.    The 
Smart Editor does not allow joints to separate.    In this situation, the Smart Editor moves the three 
rectangles together.

5. Add two new pin joints at the bottom of rectangles B and C, as indicated in figure below.
These pin joints will join the rectangles to the background.    Use the Snap Points if so desired.



6. Click the Arrow tool.
This action de-selects the pin joint tool; otherwise, further mouse clicks would create more pin joints.

7. Drag the rectangle A.
The joints pivot and the bars now move relative to one another.    The Smart Editor moves the mechanism
while making sure that pin joints do not separate.

Click the double right arrow (">>") in the above to continue.





Modifying the Link Geometry
You can use the mouse to modify the size of the links.    For example, to change the size of the left vertical
link:

1. Click on the left vertical link to select it.
Four reshape handles appear at the corners of the rectangle.

2. Bring the mouse pointer to one of the reshape handles, and hold down the mouse button.    
Drag the mouse to modify the size.
If you attached all the pin joints to Snap Points, Working Model will automatically modify the 
attachment to retain the attachment.    If the point was not attached to a Snap Point, no adjustments 
will be made.    The figure below provides a comparison between the two cases.

In both cases, the original linkage was designed so that the pin joint on the leftmost, vertical linkage was 
located near its top end.    Then the leftmost link is resized using the mouse.    Note that the linkage on the
right retains the position of the pin joint relative the link

The difference comes from one of the Working Model features, called point-based parametrics.    In 
short, the Object Snap feature is linked with an automatic specification of point positions based on the 
geometry of the bodies involved in the joint attachment.    You can turn on or off this feature as one of the 
preferences.

Click the double right arrow (">>") in the above to continue.



Precision Numerical Assembly
The Smart Editor assembles mechanisms based on numerical values.    Whenever you enter the position 
of a body, point, or joint, the Smart Editor makes sure that joints are not broken.    If necessary, the smart 
editor will move other bodies to keep the integrity of all joints in a mechanism.

Modifying Initial Configurations
You can use the Smart Editor to set the initial conditions of a simulation.    In this example, you will use the
Smart Editor to return the mechanism to its exact initial position.

1. Click the rectangle A, as indicated in the figure below.

The Coordinates bar displays the set of parameters you can edit immediately, as shown below.

2. Enter the value 0 in the orientation field of the Coordinates bar.
3. Enter a Tab or Return.

The rectangle will be moved to a position where its rotation is 0.00.    The other bodies in the 
mechanism will move to satisfy this condition.



Saving a simulation

Once your simulation is complete, you can save it to replay or edit later.

To save a simulation to disk:

1. Choose Save from the File menu.
The Save As dialog box appears if you have not yet given the simulation a name.

2. Type a name for your simulation document. Then click OK.
When you save a simulation document, the changes you made in all dialog boxes are saved too.

If you have already selected and entered a name for your simulation you can perform sequential saves 
without interrupting your work.

Use the Save As command to save a copy of your simulation under a different name.



A projectile simulation with controls and menu buttons

In this tutorial you will create a projectile simulation with controls and sliders. The simulation will be similar
to launching a golf ball off the edge of a cliff, or rolling a ball off the edge of a table. You will be able to 
control the velocity of the projectile with a slider on the screen. You will also use buttons to make a simple,
stand-alone simulation that can be easily used by others with little or no experience using Working Model.

Making the projectile simulation
Creating controls
Creating menu buttons
Player documents



Making the projectile simulation

To make the projectile simulation:

1. Create a new Working Model document by choosing New from the File menu.
2. Select the Circle tool and create a small circular mass in the middle of the workspace.
3. Select the Rectangle tool and create a rectangle right below the circle.

You create a rectangle in the same way you create circles. Click the Rectangle tool in the Toolbar, 
and then draw the rectangle on the screen. 

4. Click the tool that looks like an anchor.
The pointer becomes an anchor.

5. Click the anchor once on the rectangle.
An anchor appears on the rectangle. The rectangle is now anchored. It will not move when you run 
the simulation.    At this point, your model should look like the following:

6. Click Run in the Toolbar.
The circle bounces a few times and then comes to rest on the rectangle.

7. Click Reset in the Toolbar.



Creating controls

You will now create a simulation with an initial velocity control. In this simulation, the circle will act as a 
projectile that is fired horizontally from the left. You will use a slider control to change the initial velocity of 
the projectile (circle).

1. Drag the rectangle to the bottom-right portion of the document.
2. Select the circle.
3. Choose New Control from the Define menu. Choose Initial X Velocity from the sub menu.

A new control appears. This control specifies the initial velocity of the circle in the x (horizontal) 
direction.    See below for an example:

4. Pick an initial x velocity for the circle by using the slider to raise or lower the value.
5. Run the simulation.

Try to hit the rectangular pad by choosing the correct velocity. Reset the simulation to try again.



Creating menu buttons

You will now add menu buttons to create a simple lab for use by others who are not familiar with Working 
Model.

1. Choose New Menu Button from the Define menu.
A dialog box appears asking you to choose the menu command that you want the new button to 
perform.    A list of all menu commands and actions is displayed alphabetically.

2. Choose Run from the list.
The button appears with the name Run. Clicking on this button is the same as choosing Run from the 
Wolrd menu.

3. Click the Run button to watch the simulation.
4. Reset the simulation.
5. Choose New Menu Button from the Define menu.
6. Choose Reset from the list.

You now have a document with two menu buttons (see below):

To move a menu button:

1. Click near the button's border or drag a selection rectangle around the button to select it.
Four selection handles appear around the button.

2. Position the pointer near the selected button until the pointer changes to a crosshair.
3. Drag the button to the desired location.



Player documents

Finally, you will change this document into a player simulation. Player simulations are good for 
demonstrations, and for use by others.

Player simulations have no palette. Objects in player simulations cannot be dragged or resized. Menus in 
player simulations are greatly simplified.

1. Choose Player Mode from the Edit menu.
The palette disappears and the simulation becomes a player simulation.

2. You can run the simulation by clicking on the Run button





 Keyboard commands
You can use modifier keys in addition to the mouse    to constrain shapes when drawing objects.    Many 
Working Model menu items can be chosen with keyboard keys instead of using the mouse.    These are 
called keyboard shortcuts.    For example, pressing the F1 key is the same as choosing the Help menu.

Modifier keys
Keyboard shortcuts



Modifier keys
The following list explains modifier keys that you can use when editing objects.    Modifier keys can be 
used in conjunction with the zoom tools to toggle between Zoom In and Zoom Out.

Using the Shift key
To select more than one item, hold down the Shift key while clicking the items you want.

Clicking on an already selected object while holding down the Shift key deselects the object.

Using the Control key
Holding down the Control key while dragging the end point of a constraint will maintain its current length.   
Control-drag will also maintain the current connections of constraints and mass objects.



Keyboard shortcuts

Key Action
Control F1 Join

Control F2 Split

Shift-Control-R Runs from the last computed frame

Space bar Selects the Arrow tool

r, R Select the Rotation tool

a, A Select the Anchor tool

z Selects the Zoom in tool

Z Selects the Zoom out tool

Alt-Enter Invokes the object Properties window

Alt-Backspace Undo

Delete Clear

Shift-Delete Cut

Control-Insert Copy

Shift-Insert Paste

F1 Help

F2 New document

Alt-F4 Quit

F5 Run/Stop

F12 Save As

Shift-F12 Save

Control-F12 Open

Control-Shift-F12 Print



 Simulation Warnings

Working Model has an automatic warning feature to alert you about possible problems in your model.    If 
activated, these warnings appear while the simulation is running, or even before the first frame is 
calculated.    These warnings could indicate a serious problem with your model, and the simulation result 
may be incorrect, if not catastrophic, if the simulation is continued without corrections.

The following is a list of selected simulation warnings.    You can turn on or off these warnings in the 
Accuracy dialog box.    The High Accelerations and High Velocity warnings are controlled by a checkbox 
titled "Inaccurate Integration" in the Accuracy dialog.

 High Accelerations Warning
 High Velocity Warning
 Redundant Constraint Warning
 Inconsistent Constraint Warning
 Initial Mass Overlap Warning



 High Accelerations
This warning dialog appears when bodies undergo accelerations large enough to change velocity by 1/5 
the amount of the high velocity threshold in one simulation step.

High accelerations can be an indication that the system needs a smaller or variable (Accurate mode) time
step to be accurately simulated.    High accelerations can result from forces which are extremely large.

Try reducing the value of Time Step in the Accuracy dialog box for better accuracy.



 High Velocities
This warning dialog appears when bodies have a velocity large enough to move 20 times the maximum 
error distance in the current simulation step.    This behavior may cause a loss of accuracy, or irregular 
collisions.

Try reducing the value of Animation Step in the Accuracy dialog box to decrease the distance traveled by 
bodies between each frame.



 Redundant Constraints
This warning dialog appears when more constraints are being used than are necessary to constrain a 
specific object's motion. For example, a body with several pin joints between it and the background is 
redundantly constrained.    

One or more of the constraints will be ignored.



 Inconsistent Constraints
This warning dialog appears when conflicting constraints are being used, and the situation cannot be 
solved. For example, when a mass driven by a constant velocity motor hits a second, anchored mass.

One or more of the constraints will be ignored.



 Initial Mass Overlap
This warning dialog appears when two or more masses overlap by more than the set tolerance, and the 
bodies are not connected by joints or designated as Do Not Collide.

When two overlapping bodies collide, they may cause physical instability in the simulation.    The 
overlapping bodies should be designated as Do Not Collide by selecting the bodies and using the Do Not 
Collide option in the Object menu.    If the bodies need to collide and the message appears at frame 0, 
then the bodies need to be moved apart so they no longer overlap;    if the message appears at a later 
frame you should reduce the time step or set accuracy to Accurate mode.

The warning message indicates one pair of bodies that are overlapping (such as body[5] and body[11]).    
If your model has more than one pair of bodies overlapping each other, the warning message will keep 
appearing at RUN until all overlapping bodies are moved apart or set as Do Not Collide.

To check whether a set of bodies could collide with each other, simply select the set of bodies, and look 
under the Object menu.

 If you see a checkmark beside "Collide", the bodies could collide with one another when they come in 
contact.

 If you see a checkmark beside "Do Not Collide", the bodies will penetrate one another when they 
come in contact.

 When more than two bodies are selected and the collision property is not uniform for the bodies, 
minus ("-") signs appear beside "Collide" and "Do Not Collide"; some bodies collide while others do not.
If you wish to configure your model so that it has only a few pair of collidable bodies:
1. Choose Select All in the Edit menu.
2. Choose Do Not Collide in the Object menu to turn off all collisions.

At this point, none of the bodies will collide with others.

3. Shift-select a set of bodies that can collide, and choose Collide in the Object menu.
This way, you are turning on collision for selected bodies, and Working Model can save computing 
time since the model has fewer potential collisions to look for.






